There is a known problem with mounting ISO images on the AIX platform. To workaround the problem, complete the following instructions:
Obtain the size of the image, then identify the nearest multiple of 128 MB that will provide enough space for the image. For example, the image of CD-ROM is approximately 650/700 MB, so use 768 MB as an image size.
Make a logical volume of this size. Ensure that there is enough space on the physical volume. For example, hdisk0.
# mklv -y cdlv -s n -L /dev/cdlv rootvg 768M hdisk0
If the command fails, increase the volume size by a multiple of 128.
Use the dd command to create a pseudo-device. Ensure that the partition has enough space for the pseudo-device. In the following example command, the pseudo-device is /dev/cdlv.
# dd if=/opt/iso/cd.iso of=/dev/cdlv
Note that this command may take a long time and will create two dd processes.
Mount the device like a CD-ROM in AIX. Ensure that the mount point exists.
# mount -v cdrfs -o ro /dev/cdlv /mnt/iso